1. Create necessary FC zoning infrastructure (create zones, plug transceivers etc.) if needed. Verify using your favorite method, for example :
# fcinfo hba-port
# luxadm -e dump_map /dev/cfg/c<number_of_attachment_point>
# cfgadm -al -o show_FCP_dev
2. Create virtual volumes and provide vluns (virtual luns) to the Solaris host.
The volumes must be of equal size for one disk group.
For data disk group I would prefer thin provisioning volumes, for fast recovery area and for redo - full provisioning volumes, but it is up to you.
The amount of volumes per disk group depends on the many factors - number of active controllers, number of CPUs inside controllers, number of paths etc.; I would recommend to follow the best practices of the storage vendor at least.
3. On Solaris 11.4, the multipath I/O software is enabled by stmsboot -e command. It requires reboot when multipath support has not being enabled. If multipath was enabled before, to refresh the number of disk devices do the following :
# devfsadm -c disk
Verify that disks were created in the system using
# echo | format
Collate information using virtual volume WWN on OS and on storage area.
You may have checked the file /etc/driver/drv/fp.conf for proper multipath functionality working as well.
4. Create label of newly created disks. If disk size is less then 2TB then Solaris creates SMI Label by default. I would like to suggest to use EFI label (gpt analog in Linux), specifically when you will enlarge diskgroup and the size of each underlying disk will be more then 2TB. To do so, use -e option for format :
# format -e
and choose appropriate label type :
format> label
[0] SMI Label
[1] EFI Label
Specify Label type[1]:
The new disk device (name ends with d0) will be appear in dsk/rdsk directory
5. Configure Solaris zones (if used and needed) to see new devices. For example, to see all the devices (SAN disks) inside the zone, configure the zone as creation of device with matching :
# zonecfg -z $(hostname)-cde info
...
brand: solaris
autoboot: true
...
device:
match: /dev/rdsk/*
#
6. Make permission on new devices to grid home user and asmadmin group.
7. Create/alter diskgroup using multipath generated paths of disks like '/dev/rdsk/....s0'